User Rating: 5 / 5

Star ActiveStar ActiveStar ActiveStar ActiveStar Active
 
freeswitch-centos-rpm.png

I know, it has been a while something about FusionPBX RPM. Today, I have published in OKay's RPM repository RPMs for FusionPBX 4.4.10. FusionPBX is an open-source FreeSWITCH GUI. FusionPBX can be used as a high available, single or domain based multi-tenant PBX, carrier-grade switch, call centre server, fax server, VoIP server, voicemail server, conference server, voice application server, appliance framework and more. FreeSWITCH is a highly scalable, multi-threaded, multi-platform communication platform. FusionPBX license is the MPL 1.1 license.

This is a vanilla FusionPBX some patches from my own, mainly to be able to run correctly the load-balanced cluster mode and to fix the class-based XML CDR importer. This RPM will install MySQL (for CentOS 6) or MariaDB (for CentOS 7 or CentOS 8) as the database backend, all possible information will be stored there, such as dial plans, profile information, registrations and so on.

FusionPBX 4.4 has new things, some of them:

  • new bridges application
  • new streams application
  • new number transaction application
  • new transaction logger
  • new behaviour for the dial-plan manager
  • the directory now has a first name and last name fields

As a premium add-on, installation using this RPM includes the LCR and Billing for FusionPBX in-app. You just need to activate it and start configuring it. If you'd like to read more directions about how to install it properly in your CentOS server, you can read the quick guide covering how to install FusionPBX in a CentOS server.

I encourage everybody to upgrade to 4.4.10. If you have an installation older than November 22nd, 2019, it is very likely you have this vulnerability: https://vuldb.com/?id.146482, https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-19366; the vulnerability was reported for 4.4.1 but I did a code reviewed and it was fixed just few days ago, so if you still have 4.4.9 (and some 4.4.10), you may be vulnerable. Although the first article sounds very fatalist, the vulnerability can only be exploited after you authenticate successfully, in other words, inside-jobs.

RPM's are available for Centos 6, 7 and 8. And you can find it if you type yum search fusionpbx.

Enjoy!

blog comments powered by Disqus

About

Read about IT, Migration, Business, Money, Marketing and other subjects.

Some subjects: FusionPBX, FreeSWITCH, Linux, Security, Canada, Cryptocurrency, Trading.